Rubrik Security Cloud degraded availability

Incident Report for Rubrik

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:40 UTC

Monitoring

Rubrik Security Cloud services are recovering. We are actively monitoring the status updates from Google Cloud.
Posted Jun 12, 2025 - 20:57 UTC

Identified

Our upstream provider, Google Cloud, is experiencing an issue which impacts multiple products within Rubrik Security Cloud.
Posted Jun 12, 2025 - 19:15 UTC

Investigating

We have noticed degraded availability for Rubrik Security Cloud. We are currently investigating the issue.

Symptoms: We are still investigating the scope of the issue.

Incident Start Time: 06/12/2025 05:59 PM UTC

Workaround: None at this time.

Our engineering team is actively investigating to resolve this issue.
Posted Jun 12, 2025 - 18:55 UTC
This incident affected: US-1 (Rubrik Security Cloud), US-2 (Rubrik Security Cloud), EU-1 (Rubrik Security Cloud), CH-1 (Rubrik Security Cloud), AU-1 (Rubrik Security Cloud), US-3 (Rubrik Security Cloud), JP-1 (Rubrik Security Cloud), IN-1 (Rubrik Security Cloud), EU-2 (Rubrik Security Cloud), SG-1 (Rubrik Security Cloud), ID-1 (Rubrik Security Cloud), IL-1 (Rubrik Security Cloud), US-4 (Rubrik Security Cloud), US-5 (Rubrik Security Cloud), UK-1 (Rubrik Security Cloud), and SA-1 (Rubrik Security Cloud).