Increase in runtime for Microsoft 365 Exchange backups on Polaris
Incident Report for Rubrik
Resolved
Our monitoring indicates that the average time taken for completing Microsoft 365 Exchange backups has come down.
We thank you for your patience while we worked on resolving the issue.
Posted May 04, 2021 - 21:02 PDT
Update
We are continuing to monitor for any further issues.
Posted May 03, 2021 - 20:17 PDT
Update
We are continuing to monitor for any further issues.
Posted May 03, 2021 - 13:23 PDT
Monitoring
Our engineering team has rolled out a fix for this issue.
We are monitoring the backup performance and will provide an update in next few hours
Posted Apr 30, 2021 - 02:25 PDT
Identified
We are noticing an increase in average time taken for completing Microsoft 365 Exchange backups on Polaris.
The root-cause has been identified and we are working to mitigate the issue.

Symptoms: Exchange Mailbox backups might take longer to complete leading to drop in SLA compliance. This issue does not affect OneDrive and SharePoint backups.

Incident Start Time: We believe the impact began on 04/26/2021.

Workaround: We will temporarily increase the capacity to run more backup jobs to compensate for longer runtimes for impacted accounts.
Posted Apr 29, 2021 - 14:11 PDT
This incident affected: North American Region (Microsoft 365 Protection) and European Region (Microsoft 365 Protection).