Microsoft 365 UI Discrepancy
Incident Report for Rubrik
Resolved
This incident has been resolved.
Posted Nov 08, 2022 - 22:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 08, 2022 - 21:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 07, 2022 - 23:13 UTC
Investigating
We are noticing an issue with Rubrik Security Cloud Microsoft 365 UI across all regions.

Symptoms: The Microsoft 365 Dashboard UI is not visualizing backup event history beyond the current day. Our initial investigation shows that all protection tasks are still running as per the SLA.

Incident Start Time: 11/07/2022

Workaround: None at this time.

Rubrik is actively investigating to resolve this issue.
Posted Nov 07, 2022 - 22:02 UTC
This incident affected: US-1 (Microsoft 365 Protection), EU-1 (Microsoft 365 Protection), US-2 (Microsoft 365 Protection), CH-1 (Microsoft 365 Protection), and AU-1 (Microsoft 365 Protection).