Increased failures for Microsoft 365 Exchange protection on Polaris
Incident Report for Rubrik
Resolved
This incident has been resolved.
Posted Apr 26, 2021 - 22:47 PDT
Update
We are continuing to monitor for any further issues.
Posted Apr 26, 2021 - 21:16 PDT
Monitoring
Our engineering team has rolled out the mitigation and we are beginning to see signs of recovery from our monitoring.
We will continue to monitor and provide periodic updates until the issue is fully resolved.
Posted Apr 26, 2021 - 19:34 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 26, 2021 - 12:34 PDT
Identified
The engineering team has identified a potential mitigation and is working to implement it.
The fix will be rolled out today, we will continuously monitor the service to evaluate the effectiveness of the mitigation.
Posted Apr 26, 2021 - 09:31 PDT
Update
Our engineering team is continuing to investigate this issue with Microsoft. We will provide an update as soon as we have more information.
Posted Apr 22, 2021 - 22:09 PDT
Update
Our engineering team is continuing to investigate the root cause of this issue.
Posted Apr 22, 2021 - 10:53 PDT
Update
Our engineering team is continuing to investigate this issue.
Posted Apr 21, 2021 - 19:05 PDT
Investigating
We are experiencing increased failures for Microsoft 365 Exchange protection on Polaris for some customers due to Microsoft API errors.

Symptoms: Exchange Mailbox backups might fail. This issue does not affect OneDrive and SharePoint backups.

Incident Start Time: We believe the impact began on 04/13/2021 09:05 PM UTC with the error rate increasing starting 04/20/2021.

Workaround: None at this time.

Our engineering team is closely working with Microsoft to investigate the issue and will provide an update as soon as we have more information.
Posted Apr 21, 2021 - 14:58 PDT
This incident affected: North American Region (Microsoft 365 Protection) and European Region (Microsoft 365 Protection).