Error Accessing RSC UI

Incident Report for Rubrik

Resolved

This incident has been resolved.
Posted Feb 28, 2026 - 00:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2026 - 00:21 UTC

Investigating

RSC Login is experiencing degraded availability in EU-2 region

Symptom(s): Users are experiencing errors while attempting to log in to RSC

Workaround: None at this time.

Incident Start Time: 02/27/2026 10:24 PM UTC

Our engineering team is actively investigating to resolve this issue.
Posted Feb 27, 2026 - 23:09 UTC
This incident affected: EU-2 (Rubrik Security Cloud).