Microsoft 365 Protection Experiencing Degraded Availability
Incident Report for Rubrik
Resolved
This incident has been resolved.
Posted May 25, 2022 - 07:11 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 24, 2022 - 02:50 UTC
Identified
We are noticing an issue with Polaris Microsoft 365 protection for Exchange Mailbox in the US-1, US-2 and EU-1 regions.

Symptoms: Some Exchange Mailbox backups may fail and objects may briefly be out of compliance.

Incident Start Date: 05/23

Rubrik has identified the issue and is actively implementing a potential mitigation.
Posted May 23, 2022 - 20:01 UTC
This incident affected: US-1 (Microsoft 365 Protection), EU-1 (Microsoft 365 Protection), and US-2 (Microsoft 365 Protection).